Определите,какое число будет напечатано в результате работы следующей программы

Алгоритмический язык
нач
   цел а, b
   a :=56
   b :=a-70
   нц пока не (b>0)
       b :=b+13
   кц
   нц пока mod(a,b)<>0
         a :=a-4
   кц
  вывод а
кон

  • прога утверждает что а=48

    using System;

    namespace ConsoleApp {
        internal class Program {
            private static void Main() {
                var a = 56;
                var b = a - 70;

                while (b <= 0) {
                    b += 13;
                }

                while (a % b != 0) {
                    a -= 4;
                }
                Console.WriteLine(a);
                Console.ReadKey();
            }
        }
    }